Jump to content


Movies\Trailers Don't start from Eversion Skin on PCH A300

Movies wont start a300

  • Please log in to reply
5 replies to this topic

#1 mcos0544

mcos0544

    Member

  • Members
  • PipPip
  • 19 posts

Posted 29 July 2012 - 04:06 AM

Hello,

I have the eversion skin all setup (the way i want).. (But i'm stuck up the proverbial river without a paddle)

Started the PCH A300 and clicked on application market then YAMJ,
setup a quicklink to my Jukebox folder, Locally on A300 (local SATA drive installed)
Then eversion starts up no issue...

When i try and click on either a trailer or movie, the screen flashes then it just returns me back to the details page of the movie.

Tried different movies, different files (MKV and AVI) and nothing seems to start up for me AT ALL.

Should i be pressing something else on my remote? (apart from enter?)

Or What have i done wrong....? Its like the link to the movie(s) is not there...

Can i check a certain file that contains the links to find whats going on?

What i do to populate the A300 with the data;

On my PC,

I run a batch file (runme.bat) with the line below
MovieJukebox o:\video -o C:\Egreat\Stuff2
O:\ being my PCH A300 (movies)
C:\ being my PC Folder

I then verify that the posters etc are all fine on my PC under c:\Egreat\Stuff2 (adding the <bypassapi>true</bypassapi> in Jukebox\eversion\settings\esettings.xml)

After I verify all is good I remove the line <bypassapi>true</bypassapi>

From there i run another batch file (runme1.bat) Just to copy the contents of the jukebox folder to the PCH A300
robocopy C:\Egreat\Stuff2 o:\ *.* /e /FFT

This is what i used to do previously with my egreat... all worked like a charm

Should i not be doing this anymore?

HELP PLEASE

mcos0544

#2 accident

accident

    Administrator

  • Administrators
  • 567 posts
  • LocationNYC Area

Posted 30 July 2012 - 01:19 AM

the playerpath sounds wrong, what is inside the my_library.xml file?

#3 mcos0544

mcos0544

    Member

  • Members
  • PipPip
  • 19 posts

Posted 30 July 2012 - 11:04 AM

Hello accident,

I did some research and found a post which said that i could type in the code below in a broswert to find out what drive i had

'http://192.168.1.50:...g0=list_devices'

Result was (trimmed down)

<device>SATA_DISK</accessPath><name>SATA_DISK_1</name>harddisk</type><url>/opt/sybhttpd/localhost.drives/SATA_DISK</url></device>

So i attempted to use the YAMJ GUI and set the
Location of Directory to scan = O:\Video = \\192.168.1.50\share\video
My Video Files are on the NMT hard disk = SATA_DISK
NMT Path: 'file:///opt/sybhttpd/localhost.drives/SATA_DISK/Video/'
Location of jukebox to be stored = O:\

SO My_Library.xml looks like

<!-- Library file generated by Omertron's GUI Config -->
<!-- YAMJ GUI Config v0.51 -->
<!-- http://mediaplayersi...YAMJ_GUI_Config -->
<libraries>
<library>
<path>O:\Video</path>
<playerpath>file:///opt/sybhttpd/localhost.drives/SATA_DISK/Video/</playerpath>
<exclude name="sample,tmp/,temp/,RECYCLER/,RECYCLE.BIN/"/>
<description>Pilot1</description>
<prebuf></prebuf>
<scrapeLibrary>true</scrapeLibrary>
</library>
</libraries>

and it still didnt work!!! (So frustrated, still same thing, skin is fine but cant play movies or TV series)

So I tried as per the instructions on the single folder

We have setup the following for this example:
  • Installed a drive into a Popcorn Hour C200
  • Setup NMT and turned on Samba Server
  • Mapped the drive to our computer as P:\
  • We're going to add the Video folder
  • Screenshot below of what P:\ looks like
Let's get started
  • Click Select Dir and select the folder we want YAMJ to scan.
    • P:\Video in our case
  • Select Jukebox only for my PC.
  • Click OK for the PC warning.
  • Edit the NMT Path that appeared to ../Video
Cant really understand why you would select 'only for my PC' (but i though what the heck)
All Other settings the same;

this was the My_Library.xml
!-- Library file generated by Omertron's GUI Config -->
<!-- YAMJ GUI Config v0.51 -->
<!-- http://mediaplayersi...YAMJ_GUI_Config -->
<libraries>
<library>
<path>O:\Video</path>
<playerpath>file:///O:/Video/</playerpath>
<exclude name="sample,tmp/,temp/,RECYCLER/,RECYCLE.BIN/"/>
<description>Alpha2</description>
<prebuf></prebuf>
<scrapeLibrary>true</scrapeLibrary>
</library>
</libraries>

Reset Eversion by pressing menu + reset but...

THAT STILL DIDNT WORK!

I then tried using the SATA_DISK_A1 option

<!-- Library file generated by Omertron's GUI Config -->
<!-- YAMJ GUI Config v0.51 -->
<!-- http://mediaplayersi...YAMJ_GUI_Config -->
<libraries>
<library>
<path>O:\Video</path>
<playerpath>file:///opt/sybhttpd/localhost.drives/SATA_DISK_A1/Video/</playerpath>
<exclude name="sample,tmp/,temp/,RECYCLER/,RECYCLE.BIN/"/>
<description>Alpha5</description>
<prebuf></prebuf>
<scrapeLibrary>true</scrapeLibrary>
</library>
</libraries>

One last try I though id use HARD_DISK

<!-- Library file generated by Omertron's GUI Config -->
<!-- YAMJ GUI Config v0.51 -->
<!-- http://mediaplayersi...YAMJ_GUI_Config -->
<libraries>
<library>
<path>O:\Video</path>
<playerpath>file:///opt/sybhttpd/localhost.drives/HARD_DISK/Video/</playerpath>
<exclude name="sample,tmp/,temp/,RECYCLER/,RECYCLE.BIN/"/>
<description>Alpha7</description>
<prebuf></prebuf>
<scrapeLibrary>true</scrapeLibrary>
</library>
</libraries>

And again it didnt work.....

I'm fresh out of Ideas and really need help......

When im in the PCH A300 YAMJ Menu there is an option that says 'Player path HELP"

That displays;

Drives & pre-setup shares
HARDDISK: SATA_DISK_1

PLAYERPATH ROOT
NAME: SATA_DISK_1
TYPE: HARDDISK
FLASH & html: file:///opt/sybhttpd/localhost.drives/SATA_DISK/
EVERSION ONLY: //SATA_DISK_1

Only changes made to the install directory

Added D:\YAMJ\skins\eversion\interface\eversion\settings\esettings.xml
with the below
<settings>
<date>5</date>
</settings>

Modified D:\YAMJ\skins\eversion\eskins\evstreamed\settings-default.xml
So that <indexINDEX>wall.poster.full</indexINDEX>

My moviejukebox.properties contains the below
############################################################################################################
## Movie Jukebox properties
##
## All in one version of YAMJ+Eversion created by Accident
##
############################################################################################################
# ****** Skin/jukebox settings ******
# The Skin YAMJ should use
mjb.skin.dir=./skins/eversion

################################################################
## Multi-thread processing parameters
# Only change these values if you know what you are doing.
# The number of scanning threads
mjb.MaxThreadsDownload=64
mjb.MaxThreadsProcess=16
# The name of the jukebox folderApp requires jukebox as part of the name
#
# If your using the YAMJ Apps in the App center of your player, it must contain the name jukebox as part of
# the folder name
mjb.detailsDirName=Jukebox
# ****** YAMJ Runtime settings ******
# MediaInfo Location
#
# Unix/Linux/Mac users will need to install Mediainfo on their own and remove the # from the front of this setting
# mediainfo.home=/usr/bin/
# The show memory option can help you determine if YAMJ is failing from memory problems.
#
# If you find YAMJ stalling or not finishing while scanning your videos, change the below setting to true for YAMJ
# to be more agressive with memory management.
mjb.showMemory=false
################################################################
## Apple Trailers plugin parameters
#
# The desired resolution of trailers from apple trailers site
# Valid resolutions are: 1080p 720p 480p 640
# Choose only one of these values, if a trailer is not found at that resolution then a lower quality one will be looked for.
# Leave this blank or commented out to disable this feature
trailers.download=true
trailers.scanner.enable=true
appletrailers.download=true
appletrailers.resolution=480p
appletrailers.max=1
mjb.MaxDownloadSlots=.*=2,.*imdb.*=2,.*google.*=10,.*yahoo.*=10,.*themoviedb.*=1,.*thetvdb.*=1,.*apple.*=1
appletrailers.max=1
appletrailers.trailertypes=tlr,clip,tsr,30sec,640w
trailers.rescan.days=-1
# Timeouts for talking to internet locations.
#
# If your internet is slower or you max out your connection with downloading you should remove the # from the
# front of the below settings to increase the timeout.
# Also if you find a lot of missing TV artwork for your tv shows, we recommend uncommenting these options.
#mjb.Timeout.Read=100000
#mjb.Timeout.Connect=40000
# Overwrite Settings
#
# Set to true to have YAMJ monitor your settings and adjust overwrites as needed automatically for you.
mjb.monitorJukeboxProperties=true
# The below settings allow you to manually turn on overwrites. 99% of the time these should be false.
mjb.forceXMLOverwrite=false
mjb.forceThumbnailsOverwrite=false
mjb.forcePostersOverwrite=false
mjb.forceHTMLOverwrite=false
mjb.forceFanartOverwrite=false
mjb.forceBannersOverwrite=false
mjb.forceVideoImagesOverwrite=false
# ****** YAMJ MISC settings ******
# Episode Titles
#
# If you discover episode titles are not showing the real titles you may want to adjust this setting to true.
filename.scanner.skip.episodeTitle=false
# Create TV show Boxsets automatically (group all tv show seasons together as 1 show)
mjb.singleSeriesPage=true
# fixes a bug in some YAMJ versions that cause a load error in Eversion with tv shows that have 2 seasons.
mjb.categories.minCount=2

Hopefully someone can help because I have no idea what ive done wrong and i cant get it to work...


PLEASE HELP.

mcos0544

#4 accident

accident

    Administrator

  • Administrators
  • 567 posts
  • LocationNYC Area

Posted 31 July 2012 - 12:16 AM

<playerpath>file:///opt/sybhttpd/localhost.drives/SATA_DISK/Video/</playerpath> should be the correct one.

yamj has a reoccurring bug where it doesn't always update the jukebox xml files with the new path if that's the only setting change you made. Test by deleteing a couple of the movie records from the jukebox folder (just delete all the files with the same name as 1 or 2 files).. then run yamj again to update the jukebox and replace those flies.

You can also verify if this is the problem by looking in any xml file near the end to see what the fileURL is. Chances are it's the problem and you probably got the right path previously but the jukebox never updated.

#5 mcos0544

mcos0544

    Member

  • Members
  • PipPip
  • 19 posts

Posted 01 August 2012 - 09:36 PM

Hi Accident,

You are correct, deleted couple of the .xml files rescanned and whaalaaa movies\trailers play. I will remove the remainder and test again but im pretty sure your spot on the money!

Trying to understand how it worked on my egreat previously using only the command MovieJukebox o:\video -o C:\Egreat\Stuff2 but without implicitly using library.xml

If I was not to use the YAMJ GUI to output My_YAMJ.cmd does the above command somehow call on library.xml or is there a default if its not present?

Also whats the difference between SATA_DISK vs HARD_DISK is that SATA vs IDE? Or just the way each player picks up the internal drives.... How would a newbie know which one to use?

mcos0544

#6 accident

accident

    Administrator

  • Administrators
  • 567 posts
  • LocationNYC Area

Posted 01 August 2012 - 09:42 PM

library.xml is the default name for the file. the yamj gui does make a different named file but it also makes the cmd/bat file for you adding that in.

HARD_DISK is how the paths in a older 100 series (or oem) got to internal drives. Newer models the name could be anything and it's not as predictive as the old setup was mainly because some models do support multiple internal drives now. It's become really complicated and drive names/path can change. the Yamj app in app market has a playerpath help section to help you find the paths to your drives and shares.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users